Tuesday, October 13, 2009

Upgrading my laptop's hard disk

I work on several computers, but the one I work on most - the one I do most of my database work on, as well as all of my photo editing - is a Latitude D820. I don't know what I was thinking of when I bought a laptop with an 80GB hard drive, but it soon became clear to me that 80GB wasn't enough. After thinking about it for a long time, two days ago I finally got around to doing something about this problem. I purchased and installed a new 500GB drive. In some respects, upgrading was quite easy. In other respects, it's been, well, the word nightmare comes to mind.


Since I really didn't know what I was doing at all, I started in Dell's support forums. A helpful user explained that any 2.5" 9mm SATA drive should work in my Latitude D820. The same user also explained how it's done. You put the new drive in an enclosure and attach it to the computer; use cloning software to copy the entire contents of the internal (old) drive to the external (new) drive; shut down the computer and swap the drives; restart and go back to work. Armed with this info I headed off to Fry's Electronics. I purchased two products. First, a Seagate 2.5" SATA drive: 500 GB, 7200rpm, 16MB buffer/cache. And second, the Apricorn EZ Upgrade Universal Hard Drive Upgrade Kit.

The Apricorn EZ Upgrade kit made the hardware upgrade easy. Following the clear instructions, I installed the new drive in the Apricorn drive enclosure. I put the Apricorn CD into my CD drive and installed the software. Then I was able to use the software to clone my internal (old) hard drive, that is, to copy everything from my old 80GB hard drive (including invisible files) over to the new 500GB drive. This took several hours. When the copying was done, I shut down the computer, removed the old drive from the computer and removed the new drive from the enclosure, and then swapped them. I was able to boot the computer from the new drive. Success! Good job, Apricorn!


The hardware upgrade was easy, but unfortunately, it's not the end of the story. In fact, it is just the beginning.

I did the hardware upgrade on Monday night. On Tuesday morning, when I started up in the hope of getting back to work, I noticed the my antivirus etc software - Microsoft's One Care - was complaining that it wasn't working properly. I visited Microsoft's web site, found some troubleshooting info there that allowed me to check the active services and (apparently) correct the problem.

Then another problem appeared. After was I had been working for about 20 minutes, my laptop's screen went dark. The laptop didn't seem to go to sleep or shut down - I just lost the display, and I could not bring the display back by moving the mouse, touching a key or even touching the powerkey. Had to hold down the power key 10 seconds to force the computer to shut down, then reboot. I went back to work, and about 15-20 minutes later, it happened again. Can't work like that, so it was time to call for help.

Seagate tech support was easy to reach and courteous, and seemed to want to help, but the guy I spoke to said that, if the computer boots correctly and seems to be working (at least until the screen goes dark), then it is probably not a hard drive problem. I'm a bit skeptical because earlier versions of the drive I bought got bad consumer reviews online. But Seagate's a great company, and I've had good experience with many previous Seagate drives. He recommended that I contact Dell.


So I called Dell.

The tech support guy I reached in the morning (William) asked me to run the hardware diagnostics. I did and no errors were found. So he suggested that I upgrade my BIOS and also the driver for my NVidia video card. I did both upgrades and for a while, things seemed to be working all right.I was able to work for more than 20 minutes so far, without the screen going dark. But then I got a blue screen - something I haven't seen very many times in the four years since I started using Windows more than the Mac OS. The blue screen reported that I had experienced a "bad_pool_header" error.

So in the afternoon I called Dell again and got another support technician (Jose). More tests - and more blue screens, always the same. He took control of my computer and ran some diagnostics. We tried using the Windows installation disk to repair my installation. That didn't work either. The blue screens continued. After spending most of the day on the phone with the Dell techs, I finally had to get off the phone around 6pm to cook and eat dinner. But before I started cooking, I started the process of reinstalling Windows XP completely.

In the evening, after dinner, I returned to the computer and completed the installation of Windows. When I was finished, I was surprised to learn that I could not get to my wi-fi network. No wireless driver installed. The techs seemed to think that I should have a separate disk labeled "Drivers" but I don't, and I didn't seem to get such a disk with any of my other Dell computers, either. Anyway, called Dell a third time, got a new tech (John). With his help, I was able to download the wireless driver to my Dell desktop machine, copy it to a USB thumb drive and then install it from there on the laptop. After getting the Latitude D820 back on the wireless network, John took over my computer and installed the other necessary drivers. When that was done I did a little cleaning up, and started trying to restore files from my online backup account with Carbonite. I gave up well after midnight, leaving the computer to continue downloading files while I tried to sleep.

Are we there yet?

Not done yet, alas. This morning I woke up and started installing updates and critical apps like FileMaker Pro Advanced. As arranged the day before, Jose (the Dell tech I spent my afternoon with yesterday) called me back to see how the reinstallation had gone. I told him that, somewhat to my surprise, it appeared that the documents from the hard disk had survived the installation but that they were now in a folder to which I was denied access, even if I logged in as Administrator. He explained that I had failed to erase the hard disk properly when I did the install, and he recommended that I do the installation again, but this time that I delete the existing partition and format the disk before installing.

You can imagine how excited I was about that suggestion, but right is right, so I have taken his advice. I'm now a few minutes from the completion of the clean install....

Wrap up

So, here it is Wednesday night - exactly 48 hours after I began the process of replacing my old hard drive with the new one. I got my new drive formatted (i.e. totally erased!) this afternoon and I got Windows XP re-reinstalled. After my original reinstallation last night, I tried restoring files from my Carbonite backup, which would be great, except that it meant downloading everything over the Internet, and that was turning out to be pretty slow. So today, I took the new drive out of the computer, put the old drive back in, started the computer, and then copied the documents that I want to keep from the old drive to an external drive. Then I swapped the new drive back into the computer, booted, and copied the files from the external drive to the internal hard drive. Now I'm reinstalling applications. By the time I go to bed tonight I should be back in business. And I only lost two whole days!

I typing this with my fingers crossed (harder than it sounds) but it seems right now that everything is stable and working well. No blue screens, no video blackouts. I'm not going to be completely comfortable for a couple of weeks. Some of the folks who complained about an earlier version of the Seagate drive I installed said that their drives worked fine for the first couple of weeks. But I'll get Carbonite backing me up again tomorrow, so I should be in good shape.


So what have we learned, boys and girls? I've learned a couple of things.

  1. Installing a new hard drive in a PC isn't as hard as I thought it would be.

  2. A low-level reformat of a 500GB hard drive takes a couple of hours.

  3. Installing Windows XP itself from scratch isn't a big deal, but getting all those drivers installed is exhausting. I give Dell credit though for guiding me very well on its web site. I put in my express service code (sort of an ID for my laptop) and dell.com told me just what to install.

I hate computers.

About Me

I am an event photographer living in Dallas, Texas.